re = /<sup>(.*?)<\/sup>/
str = '<sup>3</sup>
<sup>4</sup>'
subst = '<a href="#$1"><sup>$1</sup></a>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result