const regex = /throw new UserException\('(.*)'\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('throw new UserException\\(\'(.*)\'\\)', 'g')
const str = `throw new UserException('test');
throw new UserException('require');
throw new UserException('working');
throw new UserException('okay');
throw new UserException('regular');
throw new UserException('works!');`;
const subst = `throw new UserException("$1");`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);