use strict;
my $str = 'Rs. 2000 , Rs.2000 , Rs 20,000.00 ,20,000 INR 200.25 INR';
my $regex = qr/(?:Rs\.?|INR)\s*(\d+(?:[.]\d+)*)\b(?!\,)|(?<!\d\,)\b(\d+(?:[.]\d+)*)\s*(?:Rs\.?|INR)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}