$re = '/(?:Rs\.?|INR)\s*(\d+(?:[.]\d+)*)\b(?!\,)|(?<!\d\,)\b(\d+(?:[.]\d+)*)\s*(?:Rs\.?|INR)/';
$str = 'Rs. 2000 , Rs.2000 , Rs 20,000.00 ,20,000 INR 200.25 INR';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);