re = /(?:Rs\.?|INR)\s*(\d+(?:[.]\d+)*)\b(?!\,)|(?<!\d\,)\b(\d+(?:[.]\d+)*)\s*(?:Rs\.?|INR)/
str = 'Rs. 2000 , Rs.2000 , Rs 20,000.00 ,20,000 INR 200.25 INR'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end