using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^\s#]+\s+/tmp\s+\S+\s+(\S+)";
string input = @"/dev/mapper/rootvg-lv_home /home ext4 nosuid,nodev 1 2
/dev/mapper/rootvg-lv_opt /opt ext4 nosuid,nodev 1 2
#/dev/mapper/rootvg-lv_tmp /tmp ext4 nosuid,noexec 1 2
/dev/mapper/rootvg-lv_tmp /tmp ext4 nosuid,nodev 1 2
/dev/mapper/rootvg-lv_var /var ext4 nosuid,nodev 1 2";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}