#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)(?:<[pP]>)?(?:<strong>)(?:<br \/>)?(?:<[aA]\s\w+="([?0-9–\-\/\wÅåÄäÖö;,.()\[\]&\s]+)">(?:<\/[aA]>)?)([?0-9–\-\/\wÅåÄäÖö;,.()\[\]&\s]+)(?:<\/strong>)([?0-9–\-\/\wÅåÄäÖö;,.()\[\]&\s]+)"
Local $sString = "<strong><A NAME="Bondeupproret"></A>Andersson, Per,</strong> Bondeupproret i Skåne 1811 / Per Andersson, Arne Ribnell. – [Ny, utökad uppl.]. – Malmö, 1996. – 12 s." & @CRLF & _
"<p><strong><br />Andersson, Per,</strong> Litteratur om Svedalatrakten. – Malmö[?], 197-. – 6 bl." & @CRLF & _
"<p><strong><br /><A NAME="borgar_slott"></A>Andersson, Per,</strong> Skånska borgar, slott och herrgårdar. – Lund, 1996. – 212 s." & @CRLF & _
"<p><strong><br /><A NAME="Skånska_kyrkor"></A>Andersson, Per,</strong> Skånska kyrkor, kapell, kloster och andra kyrkliga byggnader. – Malmö, 1985. – 254 s." & @CRLF & _
"<p><strong><br /><A NAME="Att_läsa"></A>Ericsson, Acke,</strong> Att läsa om Sturup. // SkNK. – 1973, h. 1, s. 37-40." & @CRLF & _
"<br />Urval ur Acke Ericssons bibliografi, se nedan." & @CRLF & _
"<p><strong><br /><A NAME="Sturup"></A>Ericsson, Acke,</strong> Sturup. – Malmö, 1973. – 24 bl." & @CRLF & _
"<p><strong><br />Jönsson, Knut,</strong> Anteckningar till en bibliografi över Bara kommun. – Borås, 1975. – 76 bl." & @CRLF & _
""
Local $sSubst = "<p><strong><a name="$1">$2</a></strong>$3</p>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)