use strict;
my $str = ' _adv_1_
Lorem ipsum dolor sit amet, consectetur adipisicing elit. Commodi consequuntur cumque eligendi et facilis ipsa perferendis possimus quasi quidem, quod rem, suscipit voluptas. Asperiores assumenda nemo repellat rerum sint, sunt?
_adv_2_
Lorem ipsum dolor sit amet, consectetur adipisicing elit. Commodi consequuntur cumque eligendi et facilis ipsa perferendis possimus quasi quidem, quod rem, suscipit voluptas. Asperiores assumenda nemo repellat rerum sint, sunt?';
my $regex = qr/(?<=_adv_)[\w\W]*?(?=_)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}