re = /(?<=_adv_)[\w\W]*?(?=_)/m
str = ' _adv_1_
Lorem ipsum dolor sit amet, consectetur adipisicing elit. Commodi consequuntur cumque eligendi et facilis ipsa perferendis possimus quasi quidem, quod rem, suscipit voluptas. Asperiores assumenda nemo repellat rerum sint, sunt?
_adv_2_
Lorem ipsum dolor sit amet, consectetur adipisicing elit. Commodi consequuntur cumque eligendi et facilis ipsa perferendis possimus quasi quidem, quod rem, suscipit voluptas. Asperiores assumenda nemo repellat rerum sint, sunt?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end