using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[quotemsg data-username=\""(.*?)\""\](.*?)\[/quotemsg\]";
string substitution = @"$2";
string input = @"[quotemsg data-username=""Александр З""]Здравствуйте,
Подскажите как можно в исходном коде статей расставить классы для заголовков H2?
Статей много - вручную не вариант.
По сути надо в цикле пройтись по всем материалам и при встрече заголовка, в зависимости от его порядка в тексте, дать ему класс.
Например классы header1, header2, header13
Сказать легко - сделать не могу[/quotemsg]Отвечаю на сообщение с первой страницы";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}