package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([+]?\d{1,2}[-\s]?|)\d{3}[-\s]?\d{3}[-\s]?\d{4}$`)
var str = `+1 504 595 1378`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}