# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.*?\b(?!www\.)((?:[\w-]+\.)+[\w-]+).*$/https:\/\/$1/gm;t' <<< "http://nike-admin.app.com
google.com
www.google.com
ftp://ftp.google.com
http://www.google.com
http://www.google.com/
https://www.google.com/
https://www.google.com.sg/
http://app.com
http://www.app.com"