import Foundation
let pattern = #"^.*?\b(?!www\.)((?:[\w-]+\.)+[\w-]+).*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://nike-admin.app.com
google.com
www.google.com
ftp://ftp.google.com
http://www.google.com
http://www.google.com/
https://www.google.com/
https://www.google.com.sg/
http://app.com
http://www.app.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"https://$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)