$re = '/^([\w-]+\.)+[a-z]{2,}$/';
$str = 'google.com.ua';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);