const regex = /^section ([^:\n]+):.*\n( +.*\n)*( +value 5\b)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^section ([^:\\n]+):.*\\n( +.*\\n)*( +value 5\\b)', 'mg')
const str = `section aaa:
some values
value 55
section eee:
some :values
value 5
section bbb:
more values
value 6
section ccc:
more values
value 7
section aaaa:
some values
value 5
section bbbb:
more values
value 6
section cccc:
more values
value 7`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}