$re = '/^section ([^:\n]+):.*\n( +.*\n)*( +value 5\b)/m';
$str = 'section aaa:
some values
value 55
section eee:
some :values
value 5
section bbb:
more values
value 6
section ccc:
more values
value 7
section aaaa:
some values
value 5
section bbbb:
more values
value 6
section cccc:
more values
value 7';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);