using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a.*(\[nggallery[^\]+]*\]).*?<\/a>";
string substitution = @"$1";
string input = @"<a href=""[nggallery id=xx]""><span class=""shutterset""><img class=""alignnone size-large wp-image-23067"" title=""Image Title"" src=""http://example.com/wp-content/uploads/2015/06/image-title.jpg"" alt="" width=""685"" height=""456"" /></span></a>
<a href=""[nggallery id=xxxxx]"">Click here!</a>
<a title=""title title"" href=""[nggallery id=xxx]"" target=""_blank"">Title Link Title Link</a>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}