const regex = /<li>[^<]*[Ss]izes[^<]*<\/li>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<li>[^<]*[Ss]izes[^<]*<\\\/li>', 'gm')
const str = `<ul><li>Option to add embroidered text personalization below design<br/>for only \$1.00 per shirt and free setup</li><li>Men's Sizes: XS-6XL</li><li>Individually folded and bagged with size sticker for easy distribution</li><li>Ready to ship in 7 business days after art approval</li></ul>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}