// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\{([A-Z0-9\-_]+)\}").unwrap();
let string = "<link href=\"{VAR_TEMPLATE_PATH}css/common.css\" rel=\"stylesheet\" type=\"text/css\">
";
let substitution = "<?php \" . $this->compile_var(\\1) . \" ?>";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}