const regex = /^((?=.*\d)(?=.*[a-z])(?=.*[A-Z])(?=.*[\/\*\-\+\.\)\(\&\%\$\#\@\!]).{6,32})$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?=.*\\d)(?=.*[a-z])(?=.*[A-Z])(?=.*[\\\/\\*\\-\\+\\.\\)\\(\\&\\%\\$\\#\\@\\!]).{6,32})$', '')
const str = `TesteDeS3nh4!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}