# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.*)_([12]?\d{1,2}\.){3}[12]?\d{1,2}_\d+\.([a-z]{3,4})$/\1.\3/i;t' <<< "pdf_of_filename_53613785621.183761237_127.10.10.0_8726347.xls"