# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d)(?=(\d{3})+\b)/$1,/g;t' <<< "1
10
100
1000
10000
100000
1000000
10000000
100000000
1000000000
10000000000
100000000000
"