$re = '/(Name|name|NAME)(?=[^()]*\))/';
$str = '( lakshd asd___ asa1123 Name : _____) Name
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);