#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[1-9]\d{0,2}(?:\,\d{1,3})?$"
Local $sString = "100" & @CRLF & _
"999,0" & @CRLF & _
"999,999" & @CRLF & _
"999,99" & @CRLF & _
"" & @CRLF & _
"-1" & @CRLF & _
"0" & @CRLF & _
"999," & @CRLF & _
"999,9999"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")