package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w+)-(?:[AR](?:-(?:NG|OK))?|[WC])$`)
var str = `Word1-A-OK
Word2-Sample-R-OK
Word3-A`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}