use strict;
my $str = 'These are some phone numbers 917-555-1234. Also,you can call me at 646.555.1234 and ofcourse I\'m always reachableat
(212)867-5309.';
my $regex = qr/\(?\d{3}[-.)]\d{3}[-.]\d{4}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}