$re = '/\(?\d{3}[-.)]\d{3}[-.]\d{4}/m';
$str = 'These are some phone numbers 917-555-1234. Also,you can call me at 646.555.1234 and ofcourse I\'m always reachableat
(212)867-5309.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);