# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/("),(\s*})/$1$2/gm;t' <<< "[{
\"s1\":\"s2\",
\"s2\":\"s3\",
},
{
\"d1\":\"d2\",
\"d3\":\"d4\",
},"