#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)("),(\s*})"
Local $sString = "[{" & @CRLF & _
" "s1":"s2"," & @CRLF & _
" "s2":"s3"," & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "d1":"d2"," & @CRLF & _
" "d3":"d4"," & @CRLF & _
" },"
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)