use strict;
my $str = '[{
"s1":"s2",
"s2":"s3",
},
{
"d1":"d2",
"d3":"d4",
},';
my $regex = qr/("),(\s*})/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";