re = /("),(\s*})/m
str = '[{
"s1":"s2",
"s2":"s3",
},
{
"d1":"d2",
"d3":"d4",
},'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result