$re = '/^(?:a(?=a*(\1?+b)))*\1?$/';
$str = 'aaaabbbb';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);