using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(--\(\* vendor\(.*\), product\(.*?\))|(\*\)--)";
string input = @"select --(* vendor(microsoft), product(odbc) guid'12345678-1234-1234-1234-123456789012' *)-- from TAB
{Jane Doe?= --(* vendor(micro1macro2?), product(cdb!o) 123$% --(**) *)-- = ?";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}