$re = '/(--\(\* vendor\(.*\), product\(.*?\))|(\*\)--)/m';
$str = 'select --(* vendor(microsoft), product(odbc) guid\'12345678-1234-1234-1234-123456789012\' *)-- from TAB
{Jane Doe?= --(* vendor(micro1macro2?), product(cdb!o) 123$% --(**) *)-- = ?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);