#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?!e\d|\\n)[a-z](?<!\\n)"
Local $sString = "azjf8ee7Ldoge \n Hmeqze= AZ12D Fs \nsdfz14eZe148r "
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)