using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^0-9.]";
string input = @"3040.302
$15,405.20
10.10,10.8,-10.9
""ele10.34.5642""
""104fflkd104.35 df10dw4.70""
""$10,000,000.04""";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}