import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?:[^,\"'\\n]*(?:(?:\"[^\"\\n]*\")|(?:'[^'\\n]*'))[^,\"'\\n]*)+)|[^,\\n]+";
final String string = "abcd,efgh, ijkl\n"
+ "abcd, efgh, ij\"k,l\", mnop, 'q,rs't\n"
+ "abcd, efgh, ij\"k,l',a\"', mnop, 'q,r,s't\n"
+ "abcd, efgh, ij\"k,l\", mnop, 'q,rs't\n"
+ "'q, rs't\n"
+ "\"'q,rs't, ij\"k, l\"\"\n"
+ "\"'q,rs't, ij\"k\"'q,rs't, ij\"k, l\"\"\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}