const regex = /(?:(?:[^,"'\n]*(?:(?:"[^"\n]*")|(?:'[^'\n]*'))[^,"'\n]*)+)|[^,\n]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?:[^,"\'\\n]*(?:(?:"[^"\\n]*")|(?:\'[^\'\\n]*\'))[^,"\'\\n]*)+)|[^,\\n]+', 'gm')
const str = `abcd,efgh, ijkl
abcd, efgh, ij"k,l", mnop, 'q,rs't
abcd, efgh, ij"k,l',a"', mnop, 'q,r,s't
abcd, efgh, ij"k,l", mnop, 'q,rs't
'q, rs't
"'q,rs't, ij"k, l""
"'q,rs't, ij"k"'q,rs't, ij"k, l""
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}