use strict;
my $str = 'abcd,efgh, ijkl
abcd, efgh, ij"k,l", mnop, \'q,rs\'t
abcd, efgh, ij"k,l\',a"\', mnop, \'q,r,s\'t
abcd, efgh, ij"k,l", mnop, \'q,rs\'t
\'q, rs\'t
"\'q,rs\'t, ij"k, l""
"\'q,rs\'t, ij"k"\'q,rs\'t, ij"k, l""
';
my $regex = qr/(?:(?:[^,"'\n]*(?:(?:"[^"\n]*")|(?:'[^'\n]*'))[^,"'\n]*)+)|[^,\n]+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}