// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?:(?:[^,"'\n]*(?:(?:"[^"\n]*")|(?:'[^'\n]*'))[^,"'\n]*)+)|[^,\n]+"#).unwrap();
let string = "abcd,efgh, ijkl
abcd, efgh, ij\"k,l\", mnop, 'q,rs't
abcd, efgh, ij\"k,l',a\"', mnop, 'q,r,s't
abcd, efgh, ij\"k,l\", mnop, 'q,rs't
'q, rs't
\"'q,rs't, ij\"k, l\"\"
\"'q,rs't, ij\"k\"'q,rs't, ij\"k, l\"\"
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}