re = /([^\s]+)/i
str = '@JoonasJQWÜPKEQÖW:DQ_D:QWÄ!"_©@©©@¶©”#¶¶©£ l.
on sitaks @tore poiss @kesdfasf haiseb@mail.ee või jaakpeldes @gmail.com'
# Print the match result
str.match(re) do |match|
puts match.to_s
end