# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[^u]es|ma$|mo|y|[mie]e|wi|ter|au"
test_str = ("mother\n"
"mom\n"
"ma\n"
"daughter\n"
"sister\n"
"wife\n"
"grandmother\n"
"grandma\n"
"aunt\n"
"niece\n"
"queen\n"
"princess\n"
"empress\n"
"duchess\n"
"marchioness\n"
"countess\n"
"baroness\n"
"baronetess\n"
"lady\n"
"dame\n\n"
"father\n"
"dad\n"
"pa\n"
"son\n"
"brother\n"
"husband\n"
"grandfather\n"
"grandpa\n"
"uncle\n"
"nephew\n"
"king\n"
"prince\n"
"emperor\n"
"duke\n"
"marquess\n"
"earl\n"
"baron\n"
"baronet\n"
"lord\n"
"knight")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.