#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([a-z0-9]+)\s+"([a-z0-9\s.]+)"\s+([a-z0-9]+)"
Local $sString = "1a "2a 2.1a 2.2a" 3a" & @CRLF & _
"4b "5.5b 5.6b 5.7b" 6b" & @CRLF & _
"7c 8c 9c"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")