$re = '/<p>\s*(https?:\/\/(?:(?!<\/?p>).)+)\s*<\/p>/';
$str = '<p>http://youtube.com/</p>
https://www.youtube.com/watch?v=mwottkiniuY';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);