#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)-----BEGIN PUBLIC KEY-----(.*)-----END PUBLIC KEY-----"
Local $sString = "KEY_ID: 1" & @CRLF & _
"STATUS: VALID" & @CRLF & _
"-----BEGIN PUBLIC KEY-----" & @CRLF & _
"MFkwEwYHKoZIzj0CAQYIKoZIzj0DAQcDQgAEaq6djyzkpHdX7kt8DsSt6IuSoXjp" & @CRLF & _
"WVlLfnZPoLaGKc/2BSfYQuFIO2hfgueQINJN3ZdujYXfUJ7Who+XkcJqHQ==" & @CRLF & _
"-----END PUBLIC KEY-----"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")