use strict;
my $str = '<title>Машины волосы мягкие и шелковистые потому что Маша пользуется Head & Shoulders</title>
Маша уже 10 лет пользуется Head & Shoulders и она очень довольна.
<!-- А это еще один title в конце документа -->
<title>Машины волосы мягкие и шелковистые потому что Маша пользуется Head & Shoulders</title>';
my $regex = qr/(?<=<title>)(?:.*)(Машины|Маша)(?:.*)(?=<\/title>)/iup;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}