using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[.\w]+\.(\w+)";
string substitution = @"$1";
string input = @"name.space.class
name.space.class<other.name.space.class1>
name.space.class<other.name.space.class1, shortSpace.class2>
class
class2
class3
Applet.Repository";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}