package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[.\w]+\.(\w+)`)
var str = `name.space.class
name.space.class<other.name.space.class1>
name.space.class<other.name.space.class1, shortSpace.class2>
class
class2
class3
Applet.Repository`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}