$re = '/\?P<([a-zA-Z]+)>(([a-zA-Z0-9-_+*:?|\[\]!<>^(),\.\\\\]+)|(?R)?)\)/';
$str = '/^\\/test\\/(?P<token>p(ae)rn)\\.(?P<format>h(((t)))))))ml)\\/$/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);