using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+)\.(\d+)\.(\d+) (\d+):(\d+):(\d+)";
string input = @"foo 24.03.2014 19:18:57 foobar foo bar
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}